All of our Gadgets are now based off of Microsoft's .NET Framework 4. Normally it comes installed on Windows PCs by default. If you're receiving a .NET Framework error, download the latest version of .NET Framework from Microsoft here.